Outils pour utilisateurs

Outils du site


logiciel:visicut

Initiation Visicut

VisiCut un logiciel libre de découpe laser !

  • Il comprend LibLaserCut, une plate-forme de bibliothèque indépendante pour Lasercutters (supportant actuellement Epilog ZING, MINI et HELIX et les découpeuse laser équipé de carte controleur LAOS et SmoothieBoard.
  • Actuellement, il prend en charge les fichiers SVG, EPS, DXF et VisiCut PLF (Portable Laser Format)
  • Obtenez un aperçu de la façon dont votre graphique regarderait le matérielFacile à placer votre graphique sur le matériau cible à l'aide d'un aperçu de l'appareil photo
  • Enregistrez votre travail et publiez-le dans le format VisiCut PLF
  • Préparez votre fichier de découpe à la maison - plus de surprises lors de l'importation de votre fichier dans le FabLab

Téléchargement sur le site: https://download.visicut.org/.

Autres outils et liens utile:

Introduction

La majorité des MOCN du Tyfab sont équipées de la smoothieboard. La smoothieboard interprète le G-code pour piloter les moteurs de la machine. Le G-code, quant à lui, est produit à partir d'un logiciel comme Cambam. Le modèle utilisé dans Cambam est un modèle 2D qui sera paramétré pour avoir le résultat escompté sur la MOCN. Le modèle 2D peut provenir d'un fichier SVG ou DXF (Inkscape peut être utilisé pour convertir le SVG en DXF).

Installation Visicut

Visicut est disponible pour la plateforme GNU/Linux, entre autres.

Sous GNU/Linux

Pour installer Visicut, il faut télécharger le paquet debian ou les fichiers sources (platform independent) sur le site indiqué ci-dessus.

Par exemple sous Debian/Ubuntu:

wget http://download.visicut.org/files/master/Debian-Ubuntu-Mint/visicut_1.8-51-gf22be37d-1_all.deb
su
dpkg -i visicut_1.8-51-gf22be37d-1_all.deb
rm visicut_1.8-51-gf22be37d-1_all.deb

Il peut être nécessaire nécessaire de commenter la ligne suivante dans le fichier '/etc/java-11-openjdk/accessibility.properties' pour que Visicut se lance correctement sous Ubuntu

assistive_technologies=org.GNOME.Accessibility.AtkWrapper

Import de la configuration TyFab

Télécharger le fichier de configuration de Visicut : lasertyfab.vcsettings.zip

Dans le fichier de configuration, la découpeuse laser est configurée pour effectuer la procédure “homing” (G28) en début de gcode, et positionner le point d'origine dans le coin inférieur gauche du plateau

puis ouvrir le menu Options > Import Settings… , puis sélectionner le fichier.

installer l'extension Inkscape : ouvrir le menu Extras > Install Inkscape-Extention…

Surtout lorsque vous utilisez Inkscape, il est recommandé d'utiliser l'extension VisiCut pour Inkscape, au lieu d'ouvrir le fichier SVG directement à partir de VisiCut.

L'extension fait un nettoyage, convertit le texte en chemin, etc.

Utilisation de Visicut

Sélection de la machine et du materiau

  1. Sélectionner la machine (ex: Redbox)
  2. Sélectionner le matériau (ex: MDF)
  3. Sélectionner l'épaisseur du matériau (ex:3mm)

chargement du dessin

Ouvrir un dessin (dxf, svg, ….) avec le menu Fichier → Ouvrir

positionner le dessin sur le plateau avec la souris, ou exactement avec l'onglet position

choix des profils de découpe

cliquer sur l'onglet “Configuration”

Choisir le mode de configuration dans la liste déroulante

ici , pour le fichier DXF, “Configuration par group/layer”

On peut associer un profil de découpe, par calque, par type d'objet, ou par couleur

associer un profil de découpe à chaque calque ici “découpe”pour le calque1, et “marquage” pour le calque2

Les ligne de découpe et de gravure apparaissent sur le plateau

Vérifier avec l’icône de configuration (roue dentée), que la case “utiliser la ligne extérieur” est décochée

Vérification des paramètres

cliquer sur l'onglet “Configuration Laser” , et vérifier les paramètres de vitesse et de puissance

La puissance est exprimée en % de la puissance max

La vitesse est exprimée en % de la vitesse maxi de la machine (10 000 mm/mn pour la RedBox)

Export du G-Code

Dans le menu Fichier, cliquer sur “Exporter le G-code”

Transfert du G-code et gravure

  • Allumer la découpeuse laser
  • Vérifier le fonctionement de
    • La Ventilation
    • Du circuit de refroidissement du tube laser
    • Du compresseur
  • Placer la planche et régler la hauteur en utilisant la jauge.

Des interfaces plus evoluées sont disponible sur http://192.168.1.54/sd/webif/index.html

  • Cliquer sur le bouton Parcourir de la section Upload File, sélectionner le fichier Gcode à charger

  • Attendre la fin du chargement puis cliquer sur le bouton Refresh de la section Printable File list

  • Le fichier apparait, cliquer sur le lien Play

Attention, ne pas rafraichir la page, ni cliquer sur un lien/bouton de cette page pendant la découpe/gravure.

  • Lorsque la gravure est terminée, supprimer le fichier Gcode, en tapant la commande rm /sd/<nom du fichier> puis cliquer sur le bouton Send

logiciel/visicut.txt · Dernière modification: 2018/11/14 10:55 par llegoff